I'm working on making a program to deal with ports (as a layer on top of ports-mgmt/synth to simplify my use of it). In the course of doing so, while creating class names, method names, etc., I've found that I don't really have satisfying and/or clear terminology for various concepts, so I'm wondering if there is official, standard-ish, and/or common terminology.
Consider both something that has flavors and something that does not; for example git and bash. Then the following distinct concepts exist in my mind, with each of the concepts described by giving it for both git and bash:
The six concepts are distinct and clear in my mind, but my names of the concepts are not. This is not a problem for me when I think about this stuff - it doesn't really matter that I think of both "default" and "git@default" as being "flavors" - but it does matter when it comes to naming the six concepts in code.
The things I've thought of to resolve this problem seem either unsatisfying in a potentially confusing way (e.g. #2 "port name" and #5 "full port name") or awfully verbose (e.g. #2 "port name" and #6 "category and port and flavor name".
This is obviously not the most important problem in the world - the "unsatisfying" or "verbose" solutions would in some sense be fine - but it has been gnawing at my brain for some time now nonetheless. So, I'm hoping for official, standard-ish, and/or common terminology.
Consider both something that has flavors and something that does not; for example git and bash. Then the following distinct concepts exist in my mind, with each of the concepts described by giving it for both git and bash:
- "devel" and "shells".
- "git" and "bash".
- "default" and null (or empty or whatever).
- "devel/git" and "shells/bash".
- "devel/git@default" and "shells/bash".
- "git@default" and "bash".
The six concepts are distinct and clear in my mind, but my names of the concepts are not. This is not a problem for me when I think about this stuff - it doesn't really matter that I think of both "default" and "git@default" as being "flavors" - but it does matter when it comes to naming the six concepts in code.
The things I've thought of to resolve this problem seem either unsatisfying in a potentially confusing way (e.g. #2 "port name" and #5 "full port name") or awfully verbose (e.g. #2 "port name" and #6 "category and port and flavor name".
This is obviously not the most important problem in the world - the "unsatisfying" or "verbose" solutions would in some sense be fine - but it has been gnawing at my brain for some time now nonetheless. So, I'm hoping for official, standard-ish, and/or common terminology.